Feature Degridation - us-east-1, us-west-1 - Actionstep Payments Unavailable - Nov 06 2025

Incident Report for Actionstep Practice Management

Postmortem

Post-Incident Summary: US – Actionstep Payments Outage – October 17, 2024

Incident Overview

On October 17, 2024, Actionstep experienced a service outage affecting the Actionstep Payments platform in the US. A configuration update inadvertently restricted access to a required system resource, which caused payment processing and related services to become temporarily unavailable.

Impact

US-based customers were unable to process payments or access related payment features for approximately one hour.

Resolution

The engineering team identified the configuration issue, restored access to the affected resource, and confirmed that all payment services were operating normally. Service was fully restored once functionality was verified across multiple customer accounts.

Next Steps

We are strengthening our change control and rollout processes to ensure configuration updates are thoroughly tested and deployed safely, with improved monitoring and communication to detect and address issues more quickly.

Acknowledgement

We sincerely apologize for the disruption this caused to our US customers. Maintaining reliable and uninterrupted access to Actionstep Payments remains a priority.

Posted Nov 07, 2025 - 10:36 NZDT

Resolved

Actionstep Payments should now be available for all users. Thank you for your patience.
Posted Nov 07, 2025 - 05:22 NZDT

Investigating

Users with Actionstep Payments may see a 403 Forbidden error when attempting to use the feature. We are currently investigating the cause.
Posted Nov 07, 2025 - 04:58 NZDT